NixOS/hardware/common.nix

13 lines
313 B
Nix

{ pkgs, lib, ... }:
let
settings = import ./../settings.nix;
in
{
hardware.bluetooth.enable = settings.hardware.bluetooth;
# for rotation sensors
hardware.sensor.iio.enable = settings.hardware.iio;
# screen and keybord backlight
hardware.acpilight.enable = settings.hardware.acpilight;
}